Labels:

Sri Lanka Telecom Mobitel, the national mobile service provider, having launched the first Super-3.5G HSPA network in South Asia in December 2007, announced that it has successfully tested HSPA+, which is capable of delivering downlink speeds of up to 28 Mbps.
In pursuit of its vision to lead Sri Lanka towards an infocom and knowledge rich society, the National Mobile Service provider has advanced its core network with latest HSPA+ powered by MIMO technology, in order to facilitate ICT infrastructure to eventually realise 'Broadband for All' in our country.

The increased speed has been achieved with the installation of MIMO (Multiple-input-multiple-output) technology which effectively uses multiple antennas in both the handset and HSPA network to split the radio signal into multiple streams, upgrading the existing network by enhancing network capacity and user experience, and thereby providing a more promising platform to offer more data based products and services to customers.

The HSPA+ trialing was possible thanks to the efforts made by its strategic technology partner Huawei, a leading mobile telecom infrastructure solutions provider in global telecom industry.

"We are happy to announce the very latest HSPA+ MIMO deployment ensures the future proofing will provide improved and superior mobile broadband experience to our customers throughout," said Leisha De Silva Chandrasena, Chairperson - Sri Lanka Telecom Mobitel.

"Not only will this highlight Mobitel's stance as the technology frontier in mobile telecom sphere, but its commitment in keeping with its pledge to offer next generation services to our valued customers."

With the launch of M3 in December 2007, Mobitel was the first in South Asia to launch HSPA technology, enabling customers to enjoy mobile broadband speeds of up to 14.4 Mbps Down link and 2Mbps uplink.

Having claimed the technology leadership in the region, Mobitel now takes another giant step making its network next G ready with the deployment of the latest HSPA+ powered by MIMO technology, which supports up to 28.8Mbps Downlink.

Yet another first in South Asia, Mobitel's HSPA+ and other complementary services will be available for its valued customers when the market is ready for commercial launch.

Suren J. Amarasekera, CEO Mobitel had this to say: "We are proud to say that Sri Lanka is in par with any other developed country in the world in terms of adoption of latest ICT technologies. Sri Lanka became the first to launch 3.5G in South Asia and now marks yet another first in the region with Mobitel's HSPA+ deployment. We firmly believe that keeping up with the latest technologies is necessary to meet the challenge of transforming our country to an infocom powered 'i-Sri Lanka' which we consider a prime duty that has been bestowed upon us as the national mobile service provider."

Labels:




Stop time of each trial version software and use them forever!

You can use this small application to use trial software forever. Time Stopper is a small utility program that can be used to run time-limited programs beyond their expiration dates. The program is not intended to be used as an aid to software piracy, rather as a tool for allowing users to evaluate software over a longer period ? users are encouraged to register any programs they find of value.


I have tried this program on several softwares and applications and it works like a charm. When used properly according to instructions (and assuming your OS has no problem), this handy little software is guaranteed to work and keep your trial period forever. ? Funbox

Please read help file for details on how to use it.


Download !!!

Labels:

Labels:

[Direct Download] Route 30

0 Comments Posted by Hirushan De Silva at 8:32 AM



there are total 9 files, 2 winrar archives.....
newfolder1 contains 3 MP4 files extract them
second one is the last part of the movie it contain a DAT file

download and reply... adding a rep will be nice to more uploads

Download Now!!

Labels:



Download DCCN3-Answers

Lab answers Provided by Russel Dharmarathne

Labels:

"Index of /admin"
"Index of /password"
"Index of /mail"
"Index of /" +passwd
"Index of /" +password.txt
"Index of /" +.htaccess
index of ftp +.mdb allinurl:/cgi-bin/ +mailto

administrators.pwd.index
authors.pwd.index
service.pwd.index
filetype:config web
gobal.asax index

allintitle: "index of/admin"
allintitle: "index of/root"
allintitle: sensitive filetype:doc
allintitle: restricted filetype :mail
allintitle: restricted filetype:doc site:gov

inurlasswd filetype:txt
inurl:admin filetype:db
inurl:iisadmin
inurl:"auth_user_file.txt"
inurl:"wwwroot/*."


top secret site:mil
confidential site:mil

allinurl: winnt/system32/ (get cmd.exe)
allinurl:/bash_history

intitle:"Index of" .sh_history
intitle:"Index of" .bash_history
intitle:"index of" passwd
intitle:"index of" people.lst
intitle:"index of" pwd.db
intitle:"index of" etc/shadow
intitle:"index of" spwd
intitle:"index of" master.passwd
intitle:"index of" htpasswd
intitle:"index of" members OR accounts
intitle:"index of" user_carts OR user_cart

Labels:




USE VISUAL DEVELOPER 2005 EXPRESS EDITION if u don't have VS2005..
only 40MB...
DOWNLOAD VS2005 EXPRESS 40MB

Download Now! ASP.NETLAB1

Labels:

R1,R2,R3--------------


Router(config)#hostname R1


Enable Secret Password:

Router(config)#enable secret class

Configure a password of cisco :R1,R2,R3

R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login

Configure a password of cisco for vty connections. R1,R2,R3

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login


Enable OSPF using process ID 1 on all routers for all networks:

R2(config)#router ospf 1
R2(config-router)#network 192.168.20.0 0.0.0.255 area 0
R2(config-router)#network 10.1.1.0 0.0.0.3 area 0
R2(config-router)#network 10.2.2.0 0.0.0.3 area 0


R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 192.168.11.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0
R2(config-router)#network 209.165.200.0 0.0.0.3 area 0


R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 192.168.11.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0

Configure a loopback interface on R2.

R2(config)#interface lo 0
R2(config-if)#ip address 209.165.200.225 255.255.255.224
R2(config-if)#no shutdown


Configure IP addresses for the VLAN 1 interface on each switch.
Switch 1:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.10.2 255.255.255.0

Switch 2:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.11.2 255.255.255.0

Switch 3:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.30.2 255.255.255.0



Configure each switch with the appropriate default gateway.

Switch 1:
Switch(config)#ip default-gateway 192.168.10.1

Switch 2:
Switch(config)#ip default-gateway 192.168.11.1

Switch 3:
Switch(config)#ip default-gateway 192.168.30.1




Task 2: Configuring a Standard ACL


R1(config)#ip access-list standard std-1
R1(config-std-nacl)#deny 192.168.11.0 0.0.0.255


R1(config)#interface fastEthernet 1/0
R1(config-if)#ip access-group std-1 in



Task 4:

R2(config)#ip access-list standard task-4
R2(config-std-nacl)#permit 10.2.2.0 0.0.0.3
R2(config-std-nacl)#permit 192.168.30.0 0.0.0.255
R2(config-std-nacl)#deny any

R2(config)#line vty 0 4
R2(config-line)#access-class task-4 in



R1#telnet 10.1.1.2

Labels:

DCCN LAB 11

0 Comments Posted by Hirushan De Silva at 7:52 PM

LAB 11 -- ACL 2

Task 1:

Task 2:
Router(config)#hostname R1



To disable DNS Lookup-(to search unknown command takes more time to disable searching)

R1(config)#no ip domain-lookup


Setting banner for the router:

R1(config)#banner motd #
Enter TEXT message. End with the character '#'.
Hirushan's router 1 #

R1(config)#

--Router 1,2,3

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#exit
R1(config)#enable password class


Pc1---Telnet

PC>telnet 10.1.1.254
Trying 10.1.1.254 ...

Hirushan's router 1

User Access Verification

Password: cisco
R1>enable
Password: class
R1#


--TElnet pc 1 to Router 2

PC>telnet 10.1.0.2
Trying 10.1.0.2 ...
User Access Verification

Password:


-telnet pc 1 to Router 3

PC>telnet 10.3.0.2
Trying 10.3.0.2 ...


User Access Verification

Password:



R1(config)#ip access-list standard hirushan
R1(config-std-nacl)#permit 10.1.0.0 0.0.0.255

R1(config)#interface fastEthernet 0/0
R1(config-if)#line vty 0 4
R1(config-line)#ip access-class hirusahn in


Check connectivity:


PC>telnet 10.3.1.1
Trying 10.3.1.1 ...

% Connection refused by remote host


R2(config)#access-list 101 deny tcp 10.1.1.0 0.0.0.255 10.3.1.0 0.0.0.255 eq telnet

R2(config)#access-list 101 permit ip any any

R2(config)#access-list 101 permit icmp any 10.1.0.2 0.0.0.0

R2(config)#access-list 101 permit tcp any any eq 80

R2(config-if)#ip access-group 101 in

Labels:

DCCN LAB 13

0 Comments Posted by Hirushan De Silva at 7:50 PM

Lab13-DCCN

HeadQ-

Router(config-if)#encapsulation frame-relay
Router(config-if)#no shut
Router(config-if)#exit
Router(config)#interface serial 1/0.102 point-to-point
Router(config-subif)#ip address 192.168.102.1 255.255.255.0
Router(config-subif)#frame-relay interface-dlci 102



For other routers-Use main interface
Router(config)#interface serial 1/0
Router(config-if)#encapsulation frame-relay
Router(config-if)#ip address 192.168.103.2 255.255.255.0
Router(config-if)#frame-relay interface-dlci 301

FrameRelay-
Ser0- DLCI-102 Head to Kandy
DLCI-103 Head to Galle

Ser 1-DLCI-201 Kandy To HeadQ

Ser 2 -DLCI-301 Galle to HeadQ

kandy
Router(config)#router eigrp 1
Router(config-router)#network 200.200.102.0 0.0.0.255
Router(config-router)#network 192.168.102.0 0.0.0.255

HQ-
Router(config)#router eigrp 1
Router(config-router)#network 192.168.102.0 0.0.0.255
Router(config-router)#network 192.168.103.0 0.0.0.255
Router(config-router)#network 10.10.10.0 0.0.0.255

Galle-
Router(config)#router eigrp 1
Router(config-router)#network 192.168.103.0 0.0.0.255
Router(config-router)#network 200.200.103.0 0.0.0.255

Labels:

WebServices (web methods)

0 Comments Posted by Hirushan De Silva at 7:41 PM

Download!

Labels:

 

View Video Tutorial

Created By Hirushan De Silva (oct-04-2009)

Labels:

Lab 2 Sinhala Video Tutorial 

Any Comments ??

Labels:

VB Decompiler v7.6

0 Comments Posted by Hirushan De Silva at 8:16 AM

Decompiler for Visual Basic writen programs.

VB Decompiler is decompiler for programs (EXE, DLL or OCX) written in Visual Basic 5.0 and 6.0 and disassembler for programs written on .NET technology.
The loss of source codes is a very serious problem for many developers. From my personal experience I can say that it is indeed a terrible misfortune. Imagine you write the program, spend your force, time and money, release compiled program to the customers... But one morning you see that all your sources are gone (it may be your cat, or aliens. Who knows?) You are in panic. What should you do? Tear one's hair? There is no need. Just take the VB Decompiler and simply decompile your project! VB Decompiler restores the source code from the pseudo code (P-Code) as close as possible to the original. So, after some modifications you may get really workable source code.


But you ask: what if the program is compiled not to interpreted P-Code, but in assembler Native Code? In this case, of course, you can't get fully compilable source code. But there is no need for disappointment. VB Decompiler has a built-in powerful disassembler and emulator commands to the extent possible to bring the assembly code to the original. Of course because of the diversity of modern methods of optimization and protection code, the process is not always ideal, but in this situation, VB Decompiler really helps you in the software analysis and reverse engineering.


And what if you develop in Visual Studio, using .NET Framework?


For our decompiler it's not a problem! VB Decompiler can easily restore the structure from the tables of the assembly, and will be useful for disassembly and analysis of IL code. Our decompiler does not require .NET Framework. It works fine in any 32-bit Windows operating systems and does not require installing additional software.
As you can see VB Decompiler is an ideal tool for analyzing and restoring the source code. VB Decompiler is a "must-have" tool for VB-developers, who appreciates their work, time and money.

Minimum System Requirements: Pentium 166, 32Mb RAM, Windows 95/98/ME/2k/XP/2003/Vista.
Homepage and more info here:

Code:

http://www.vb-decompiler.org/

Download Application and Working Patcher from here:

Code:

http://rapidshare.com/files/279100381/VBDecomp76Pro.rar

Archive Password: just4you

Labels:

Google Wave

0 Comments Posted by Hirushan De Silva at 8:04 AM

Labels:

sharing your existing ethernet internet connection

1. go to control panel -> network connection.
2. right click on your ethernet connection and click on “properties”.
3. go to “advanced” tab.
4. check “allow other network….. internet connection”
5. in the drop down below select the wifi connection of your pc. if it is disabled, it will be showing your wifi connection already.
6. click on “settings”
7. check the protocols you need to share.i normally use only http and https.
8. click on “ok”.you reach the network connection page. the sharing part is now over.

finding dns server ip address.

1. click on start -> run
2. type in cmd in the run prompt
3. in the new window type “ipconfig /all” and press enter.
4. note down your dns server ip address from the screen.

configuring the wifi

1. go again to control panel -> network connections.
2. right click on your wifi connection and click “properties”.
3. go to”wireless network” tab.
4. the “use windows to configure my wireless network connection” should be checked.
5. in the preferred network connection section click on add button
6. enter a name of your wish to the network name.
7. network authentication is “open”
8. change data encryption to “disabled”
9. check the “this is a computer to computer …. not used” connection.
10. click “ok”.
11. click on general tab. select “internet protocol(tcp/ip) and click on properties button.
12. now type 192.168.0.1 in ip address, 255.255.255.0 in subnet mask, leave default gateway empty.
13. fill in the dns server entry which you had noted down earlier.
14. click on “ok” and your network is set.

your network should appear on the wifi network list now. search for wlan on your phone. connect and enjoy browsing on your phone.

Thanks....................

Labels:


ඔබේ අනාගතය දැනගන්න (Know ur Future)
Download this software to know it

Download


uploader:
retuom (elakiri.com)

Labels:



Download Now!

Labels:

--execute UTLXPLAN.sql & SampleDB.sql

select c.clno, c.name
from client c, purch p
where c.clno = p.clno and p.qty>1000;

--the following will find the better query plan

explain plan for
select c.clno, c.name
from client c, purch p
where c.clno = p.clno and p.qty>1000;

--to see the query plan

select * from PLAN_TABLE;

--to format the output use the utlxpls_mod.sql file

--to see the values

alter session set optimizer_mode=all_rows;
alter session set "_optimizer_cost_model" = cpu;

--after altering again explaing the plan & select * from PLAN_TABLE, then run the utlxpls_mod.sql, then your cost values should be there


--getting another query plan

explain plan for
select t.*
from trading t
where t.exchange='Tokyo';


--PLAN_TABLE

Plan Table
--------------------------------------------------------------------------------
| Operation and options | Object | cost | cpu_cost | io_cost |
--------------------------------------------------------------------------------
| SELECT STATEMENT | | 4 |125588 | 3 |
| TABLE ACCESS FULL |TRADING | 4 |125588 | 3 |
--------------------------------------------------------------------------------

TABLE ACCESS FULL - since there is no index in the table, when you create index the cost will be reduced.

--creating index for the trading table

create index index_3 on trading(exchange);

--after creating the index the cost reduces

Plan Table
--------------------------------------------------------------------------------
| Operation and options | Object | cost | cpu_cost | io_cost |
--------------------------------------------------------------------------------
| SELECT STATEMENT | | 3 |21735 | 2 |
| TABLE ACCESS BY INDEX ROWID |TRADING | 3 |21735 | 2 |
| INDEX RANGE SCAN |INDEX_3 | 2 |14443 | 1 |
--------------------------------------------------------------------------------


--to drop an index

drop index [index_name];

--all the indexes will be stored inside the user_indexes table

select index_3
from user_indexes
where table_name='TRADING'
/

--if you used simple letters for trading when creating the table, you have to use capital letters while selecting the index [TRADING]



select index_name
from user_indexes
where table_name='TRADING'
/

INDEX_NAME
------------------------------
INDEX_3
SYS_C0023391

--SYS_C0023391 is the system generated index, and is created for primary keys.
--INDEX_3 is the index we created



select DBMS_METADATA.GET_DDL('INDEX', u.index_name)
from user_indexes u
where table_name = 'TRADING'
/


DBMS_METADATA.GET_DDL('INDEX',U.INDEX_NAME)
--------------------------------------------------------------------------------

CREATE INDEX "DIT7C1_0055"."INDEX_3" ON "DIT7C1_0055"."TRADING" ("EXCHANGE")


CREATE UNIQUE INDEX "DIT7C1_0055"."SYS_C0023391" ON "DIT7C1_0055"."TRADING" (





--creating index for client table

create index index_3 on client


DBMS 7 answer provided by Russel Dharmarathne!..

Labels:

Cyclomatic Complexity

0 Comments Posted by Hirushan De Silva at 8:01 AM

Labels:



Angel -SLIIT Talent Show 2009

0 Comments Posted by Hirushan De Silva at 8:18 AM

Part 1:
Router1 configuration.......


router(config)#router ospf 1
Router(config-router)#network 172.16.10.0 0.0.0.255 area 0 //backbone area (same domain)
Router(config-router)#network 10.10.10.196 0.0.0.3 area 0
Router(config-router)#network 10.10.10.200 0.0.0.3 area 0

Router2

Router(config)#router ospf 1
Router(config-router)#network 10.10.10.192 0.0.0.3 area 0
Router(config-router)#network 10.10.10.196 0.0.0.3 area 0
Router(config-router)#network 192.168.10.0 0.0.0.255 area 0

Router 3
Router(config)#router ospf 1
Router(config-router)#network 10.10.10.192 0.0.0.3 area 0
Router(config-router)#network 10.10.10.200 0.0.0.3 area 0
Router(config-router)#network 172.16.10.32 0.0.0.31 area 0

Part 2:
Router#show ip route

Part 3:
Router#show ip ospf database

Router ID's :
Router 1:
OSPF Router with ID (172.16.10.1)
Router 2:
OSPF Router with ID (192.168.10.1)
Router 3:
OSPF Router with ID (172.16.10.33)


Part 5:
PC>tracert 172.16.10.33

Shortest Path

Labels:

SLIIT DCCN III - LAB 10 Answer

0 Comments Posted by Hirushan De Silva at 6:52 AM

R1,R2,R3--------------


Router(config)#hostname R1


Enable Secret Password:

Router(config)#enable secret class

Configure a password of cisco :R1,R2,R3

R3(config)#line console 0
R3(config-line)#password cisco
R3(config-line)#login

Configure a password of cisco for vty connections. R1,R2,R3

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login


Enable OSPF using process ID 1 on all routers for all networks:

R2(config)#router ospf 1
R2(config-router)#network 192.168.20.0 0.0.0.255 area 0
R2(config-router)#network 10.1.1.0 0.0.0.3 area 0
R2(config-router)#network 10.2.2.0 0.0.0.3 area 0


R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 192.168.11.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0
R2(config-router)#network 209.165.200.0 0.0.0.3 area 0


R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 192.168.11.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0

Configure a loopback interface on R2.

R2(config)#interface lo 0
R2(config-if)#ip address 209.165.200.225 255.255.255.224
R2(config-if)#no shutdown


Configure IP addresses for the VLAN 1 interface on each switch.
Switch 1:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.10.2 255.255.255.0

Switch 2:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.11.2 255.255.255.0

Switch 3:

Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.30.2 255.255.255.0



Configure each switch with the appropriate default gateway.

Switch 1:
Switch(config)#ip default-gateway 192.168.10.1

Switch 2:
Switch(config)#ip default-gateway 192.168.11.1

Switch 3:
Switch(config)#ip default-gateway 192.168.30.1




Task 2: Configuring a Standard ACL


R1(config)#ip access-list standard std-1
R1(config-std-nacl)#deny 192.168.11.0 0.0.0.255


R1(config)#interface fastEthernet 1/0
R1(config-if)#ip access-group std-1 in



Task 4:

R2(config)#ip access-list standard task-4
R2(config-std-nacl)#permit 10.2.2.0 0.0.0.3
R2(config-std-nacl)#permit 192.168.30.0 0.0.0.255
R2(config-std-nacl)#deny any

R2(config)#line vty 0 4
R2(config-line)#access-class task-4 in



R1#telnet 10.1.1.2

Labels:

Labels:



Cisco ACL Editor and Simulator
Cisco ACL Editor and Simulator can create Standard and Extended ACLs, edit Standard and Extended ACLs and simulate their use on a Cisco Router. You can save both Standard and Extended ACLs in their respective files and export all the ACLs to the Clipboard for pasting into HyperTerminal!



Features

Create Standard ACLs
Create Extended ACLs – Using IP, TCP, UDP and ICMP Protocols.
Edit Standard and Edit Extended ACLs
Visually Simulate Standard ACLs
Visually Simulate Extended ACLs
Save Standard ACLs as .sacl as XML
Save Extended ACLs as .eacl as XML
Export Standard and Extended ACLs – Ready for HyperTerminal

Download 30 day trial

Labels:


This is the best Emulator
to play JAR (Mobile Games)
on to your PC.........

You just need to do is to
open that JAR file with this
software..........

Enjoy Playing JAR games with this.........

Download!

Labels:

Mobile Phone—>> Web Camera

Whenever you need a high-quality web camera, just take your Symbian
phone from a pocket! With Mobiola Web Camera software you can throw
away your bulky USB webcam. It works with most Windows applications and
online services, very simple to install and easy to use.

- Transforms your mobile phone into high-quality PC webcamera.
- Works through WiFi (NEW!), Bluetooth or USB.
- Screen Capture functionality, when device screen can be demonstrated on PC real-time.
- Cool video effects, to have fun with your friends. - NEW!
- Works with Skype, Yahoo, YouTube, MSN, AOL IM, ICQ and many others.
- Compatible with Windows Vista/XP/2003/2000.

Download!

 

Technorati Tags:


Deep in the heart of the desert, far from civilization, there's a hidden treasure cave. People say that priceless treasures of unseen beauty are hidden there, but the cave is locked and no one can enter. Can you finesse the stones and unlock the treasure cave? Fresh and fun match-3 game with addicting mechanics, beautiful graphics and rich music. Break the walls, collect the treasures and build up your own land to make your dream come true! Unique bonuses and challenging obstacles will provide hours of amusement and pure fun!
System requirements:
Windows 98/ME/2000/XP/Vista
DirectX 7
800 MHz
256 MB RAM
Download Links:

Download!


Speedup Your Typing 2.9.4

0 Comments Posted by Hirushan De Silva at 5:39 PM

Technorati Tags:

The most important and basic score is "words per minute", or "wpm" for short. Often, this is a corrected score, where each error made during the test reduces the "words per minute" by one. Another common score is an accuracy percentage -- which is simply the number of words you got right compared to how many you typed. For instance, 90% accuracy means you averaged 9 out of 10 words right.
So, how fast can you type? The simple typing test calculator below will calculate your speed (words per minute).

Download Now!


Description:
VMware Workstation makes it simple to create and run multiple virtual machines on your desktop or laptop computer. You can convert an existing physical PC into a VMware virtual machine, or create a new virtual machine from scratch. Each virtual machine represents a complete PC, including the processor, memory, network connections and peripheral ports.
VMware Workstation lets you use your virtual machines to run Windows, Linux and a host of other operating systems side-by-side on the same computer. You can switch between operating systems instantly with a click of a mouse, share files between virtual machines with drag-and-drop functionality and access all the peripheral devices you rely on every day.
Release name: VMWare.Workstation.v6.5.3.185404.Incl.Keygen

Part 1

Part 2

Part 3

Technorati Tags:


Pepakura Designer v3.0.3b

0 Comments Posted by Hirushan De Silva at 11:51 AM

Pepakura Designer makes it easy to design original papercraft patterns by importing 3D model data. No special knowledge is required for making papercraft patterns. All you have to do is prepare the 3D model. You may use some 3DCG software released from other developers to make the 3D models for unfolding.
Windows 2000/XP/Vista

 

Download

password : sherwood@cw

Labels:

SETM LAB 5:)
2009 AUG 21

cd "Z:\SETM lab5"

Bytecodeparser
->constant pool symbol table

Z:\SETM lab5>java setm.metrics.ByteCodeParser

open ->prac4.class

-------------------------output------------------------

Constant Pool Symbol Table
Entry Tag Value
0 undefined (0) undefined
1 CONSTANT_Utf8 bytes=
2 CONSTANT_Utf8 bytes=()V
3 CONSTANT_Utf8 bytes=mystery
4 CONSTANT_Utf8 bytes=(II)I
5 CONSTANT_Utf8 bytes=Code
6 CONSTANT_Utf8 bytes=
7 CONSTANT_NameAndType name[0x6]= descriptor[0x2]=()V
8 CONSTANT_Utf8 bytes=java/lang/Object
9 CONSTANT_Classref index[0x8]=java/lang/Object
a CONSTANT_Methodref class[0x9]=java/lang/Object NameAndType[0x7]
= ()V
b CONSTANT_Utf8 bytes=SourceFile
c CONSTANT_Utf8 bytes=Prac4
d CONSTANT_Classref index[0xc]=Prac4
e CONSTANT_Utf8 bytes=prac04.java

end of ConstantPoolTable


Parsing classs area in class files is not supported in this version


Z:\SETM lab5>java setm.gui.HexViewer


------------------output----------------------


0: ca fe ba be 00 03 00 - 00 0f 01 00 08 < c l
15: i n i t > 01 00 03 ( ) V 01 00 07 m y
31: s t e r y 01 00 05 ( I I ) I 01 00 04
47: C o d e 01 00 06 < i n i t > 0c 00 06
63: 00 02 01 00 10 j a v a / l a n g / O
79: b j e c t 07 00 08 0a 00 09 00 07 01 00 0a
95: S o u r c e F i l e 01 00 05 P r a
111: c 4 07 00 0c 01 00 0b p r a c 0 4 . j
127: a v a 00 ! 00 0d 00 09 00 00 00 00 00 02 00
143: 09 00 03 00 04 00 01 00 05 00 00 00 15 00 02 00
159: 02 00 00 00 09 1a 1b a2 00 05 1a ac 1b ac 00 00
175: 00 00 00 01 00 06 00 02 00 01 00 05 00 00 00 11
191: 00 01 00 01 00 00 00 05 * b7 00 0a b1 00 00 00
207: 00 00 01 00 0b 00 00 00 02 00 0e

magic: ca fe ba be
minor version: 00 03
major version : 00 -
constant pool count : 00 0f -15
-----------------------------
inside constant pool table we need to have 130 bytes:
-----------------------------

access flags: 00 0! public
name of the class :00 0d Prac4
name of the super_class : 00 09 java/lang/object
the number of interfaces implemented : 00 00
the number of fields :00 00
the number of methods:00 02

---------------Methods-------------
-------------------------------------------------------------------------
*****Constructor methods cannot analysed **********
-------------------------------------------------------------------------
2 methods -constructor class & mystery method
-------------------------------------------------------------------------
• access flags :00 09 public static
• name of the class :00 03 mystery
• return type and the types of all parameters :00 04(I I)I

return type: integer Parameter types: integer (2 parameters)
attribute-00 01
• the number of bytes in the code attribute



code length=00 00 00 09

1a 1b a2 00 05 1a ac 1b ac


--------------------------------Part 6----------------------------------

Z:\SETM lab5>javap -l -c Prac4

--------------------------------output----------------------------------


Compiled from "prac04.java"
public class Prac4 extends java.lang.Object{
public static int mystery(int, int);
Code:
0: iload_0
1: iload_1
2: if_icmpge 7
5: iload_0
6: ireturn
7: iload_1
8: ireturn




public Prac4();
Code:
0: aload_0
1: invokespecial #10; //Method java/lang/Object."":()V
4: return




}


------------------------------------



• Determine the number of return statements contained in method. = 2
• Determine if this method follows generally accepted coding standards and justify your answer.

Labels:

CREATE TYPE manufacture_ty as OBJECT(
name varchar(20),
country varchar(20)
)
/

CREATE TYPE product_ty AS OBJECT(
modelno number,
type varchar(10),
price number(8,2),
name ref manufacture_ty
)NOT FINAL;
/


CREATE TYPE computer_ty UNDER product_ty (
speed number,
ram number,
hdisksize number,
rdspeed varchar2(3),
rdtype varchar2(3)
)NOT FINAL;
/

CREATE TYPE printer_ty UNDER product_ty(
PRType varchar2(8),
ifcolour varchar2(5)
)
/

CREATE TYPE pc_ty UNDER computer_ty(
monitorsize number(2),
casetype varchar2(5)
)
/

CREATE TYPE laptop_ty UNDER computer_ty(
screen number(8,2),
weight number(8,2)
)
/


CREATE TABLE manufacture_tab of manufacture_ty(
constraint pk_manufacture_tabl primary key(name)
)
/

CREATe TABLE product_tab of product_ty
(
constraint pk_product_tab primary key (modelno),
constraint fk_procut_tab foreign key(name) references manufacture_tab
)
/


insert into manufacture_tab values('ACER','SINGAPORE');
insert into manufacture_tab values('COMPAQ','USA');
insert into manufacture_tab values('IBM','USA');
insert into manufacture_tab values('TOSHIBA','JAPAN');
insert into manufacture_tab values('HP','USA');
insert into manufacture_tab values('CANON','JAPAN');

insert into product_tab values(
pc_ty(1001,'PC',1799,(select ref(b) from manufacture_tab b where b.name='ACER'),2700,256,40,'48x','CD',15,'tower'))
/

insert into product_tab values(
pc_ty(1002,'PC',2499,(select ref(b) from manufacture_tab b where b.name='ACER'),3500,512,60,'64x','DVD',17,'tower'))
/

insert into product_tab values(
pc_ty(1003,'PC',1999,(select ref(b) from manufacture_tab b where b.name='ACER'),1800,512,30,'48x','DVD',15,'flat'))
/

insert into product_tab values(
pc_ty(1004,'PC',1999,(select ref(b) from manufacture_tab b where b.name='IBM'),1800,256,40,'64x','DVD',15,'flat'))
/

insert into product_tab values(
pc_ty(1005,'PC',2499,(select ref(b) from manufacture_tab b where b.name='IBM'),4000,512,60,'64x','DVD',15,'flat'))
/

insert into product_tab values(
pc_ty(1006,'PC',2119,(select ref(b) from manufacture_tab b where b.name='IBM'),2300,1024,40,'96x','DVD',17,'tower'))
/

insert into product_tab values(
pc_ty(1007,'PC',2299,(select ref(b) from manufacture_tab b where b.name='COMPAQ'),2400,512,80,'64x','DVD',17,'tower'))
/

insert into product_tab valueS(
pc_ty(1008,'PC',1999,(select ref(b) from manufacture_tab b where b.name='COMPAQ'),2700,256,30,'96x','CD',15,'tower'))
/

insert into product_tab values(
pc_ty(1009,'PC',1699,(select ref(b) from manufacture_tab b where b.name='TOSHIBA'),3200,512,80,'64x','DVD',17,'tower'))
/

---------------

insert into product_tab values(
laptop_ty(2001,'LP',1448,(select ref(b) from manufacture_tab b where b.name='ACER'),1700,256,40,'48x','CD',12.1,3.5))
/

-----------

insert into product_tab values(
laptop_ty(2002,'LP',2559,(select ref(b) from manufacture_tab b where b.name='ACER'),2200,512,30,'64x','DVD',15.1,3.1))
/

insert into product_tab values(
laptop_ty(2003,'LP',2799,(select ref(b) from manufacture_tab b where b.name='ACER'),1866,512,60,'48x','DVD',15.1,2.8))
/

insert into product_tab values(
laptop_ty(2004,'LP',1999,(select ref(b) from manufacture_tab b where b.name='IBM'),1866,256,40,'64x','DVD',12.1,3.5))
/

insert into product_tab values(
laptop_ty(2005,'LP',1499,(select ref(b) from manufacture_tab b where b.name='IBM'),1700,256,60,'64x','DVD',12.1,3.1))
/

insert into product_tab values(
laptop_ty(2006,'LP',2119,(select ref(b) from manufacture_tab b where b.name='IBM'),3700,1024,80,'64x','DVD',15.7,3.1))
/

insert into product_tab values(
laptop_ty(2007,'LP',2229,(select ref(b) from manufacture_tab b where b.name='COMPAQ'),2900,512,80,'48x','DVD',15.1,3.5))
/

insert into product_tab values(
laptop_ty(2008,'LP',999,(select ref(b) from manufacture_tab b where b.name='COMPAQ'),1700,256,30,'96x','DVD',12.1,3.6))
/

insert into product_tab values(
laptop_ty(2009,'LP',699,(select ref(b) from manufacture_tab b where b.name='TOSHIBA'),1800,128,40,'64x','DVD',15.1,2.9))
/

insert into product_tab values(
laptop_ty(2010,'LP',1699,(select ref(b) from manufacture_tab b where b.name='TOSHIBA'),2750,512,30,'96x','CD',12.1,3.0))
/

------------
insert into product_tab values(
printer_ty(3001,'PR',231,(select ref(b) from manufacture_tab b where b.name='HP'),'ink-jet','True'))
/
-------------
insert into product_tab values(
printer_ty(3002,'PR',267,(select ref(b) from manufacture_tab b where b.name='CANON'),'ink-jet','True'))
/

insert into product_tab values(
printer_ty(3003,'PR',390,(select ref(b) from manufacture_tab b where b.name='HP'),'laser','False'))
/

insert into product_tab values(
printer_ty(3004,'PR',439,(select ref(b) from manufacture_tab b where b.name='CANON'),'ink-jet','True'))
/

insert into product_tab values(
printer_ty(3005,'PR',200,(select ref(b) from manufacture_tab b where b.name='CANON'),'bubble','True'))
/

insert into product_tab values(
printer_ty(3006,'PR',1999,(select ref(b) from manufacture_tab b where b.name='IBM'),'laser','True'))
/

insert into product_tab values(
printer_ty(3007,'PR',350,(select ref(b) from manufacture_tab b where b.name='HP'),'laser','False'))
/

--Q4.
--a

select p.name.name,treat (value(p) as pc_ty).speed
from product_tab p
where value(p) IS OF(pc_ty) and
treat(value(p) as pc_ty).hdisksize>=60
/

--b

select p.modelno,p.price
from product_tab p
where p.name.name like 'C%'
/

--c
select distinct p.name.name
from product_tab p
where value(p) is of (only pc_ty)
/

--OR

--C-
select distinct p.name.name
from product_tab p
where value(p) IS OF (pc_ty) and
p.name.name NOT IN (select p1.name.name
from product_tab p1
where value(p) IS OF(printer_ty))

--d
select p.name.name
from product_tab p
where value(p) is of (pc_ty)
group by p.name.name
having count(p.modelno)>=3
/

--e
select p.name.name,avg(treat(value(p) as laptop_ty).screen)
from product_tab p
where value(p) IS OF (laptop_ty)
group by p.name.name
/


--Q5-A)

alter type product_ty add member function print return integer cascade
/

create or replace type body product_ty AS
MEMBER function print return integer is
begin
return self.modelno;
end print;
end;
/


--b
alter type computer_ty add overriding member function
print return integer cascade
/

create or replace type body computer-Ty as
overriding mbmerber function print return integer is
begin
return 'Model NO:'||self.modelno||'SPEED:'||self.speed||'RAM:'||self.ram||'HDSIZE'||self.hdiskskize
end print;
end;
/


select p.print()
from product_tab p


select p.print()
from product_tab p
where value(p) is of (pc_ty)

select p.print()
from product_tab p
where value(p) IS OF (computer_ty)

Labels:



Download Now

Labels:


--DBMS ANSWER's Provided by Iranga & Sachit --


--1

--a)
ALTER TYPE stock3_t ADD MEMBER FUNCTION getYield RETURN FLOAT CASCADE;

--B)
ALTER TYPE stock3_t ADD MEMBER FUNCTION toUSD(rate IN FLOAT) RETURN FLOAT CASCADE;

--c)
ALTER TYPE stock3_t ADD MEMBER FUNCTION countExchanges RETURN INTEGER CASCADE;

--d)
ALTER TYPE client3_t ADD MEMBER FUNCTION totalPurchase RETURN FLOAT CASCADE;

--e)
ALTER TYPE client3_t ADD MEMBER FUNCTION totalProfit RETURN FLOAT CASCADE;



CREATE OR REPLACE TYPE BODY stock3_t AS
MEMBER FUNCTION getYield RETURN FLOAT IS
BEGIN
RETURN ( (SELF.dividend / SELF.currprice)*100 );
END getYield;

MEMBER FUNCTION toUSD(rate IN FLOAT) RETURN FLOAT IS
BEGIN
RETURN (SELF.currprice * rate);
END toUSD;

MEMBER FUNCTION countExchanges RETURN INTEGER IS
countEx INTEGER;
BEGIN
SELECT COUNT(e.COLUMN_VALUE) INTO countEx
FROM TABLE(SELF.exchangeS)e ;
RETURN countEx;
END countExchanges;

END;
/

CREATE OR REPLACE TYPE BODY client3_t AS
MEMBER FUNCTION totalPurchase RETURN FLOAT IS
total FLOAT;
BEGIN
SELECT SUM(s.purchaseprice*s.qty) INTO total
FROM TABLE(SELF.investments)s;
RETURN total;
END totalPurchase;

MEMBER FUNCTION totalProfit RETURN FLOAT IS
profit FLOAT;
BEGIN
SELECT SUM(s.qty *(s.company.currprice - s.purchaseprice) ) INTO profit
FROM TABLE (SELF.investments)s;
RETURN profit;
END totalProfit;

END;
/

--2)
--a)
SELECT s.company AS CNAME,s.exchangeS AS EXCHANGES ,s.toUSD(0.74) AS USDPRICE ,s.getYield() AS YIELD
FROM stock3 s;

--b)
SELECT s.company AS CNAME ,s.currprice AS CPRICE ,s.countExchanges() AS CNT_eXCHANGES
FROM stock3 s
WHERE s.countExchanges() > 1 ;

--c)
SELECT DISTINCT c.name AS NAME ,I.company.company AS STK_NAME,I.company.getYield() AS YIELD,I.company.currprice AS CPRICE,I.company.eps AS EPS
FROM client3 c, TABLE(c.investments)I ;

--d)
SELECT DISTINCT c.name AS NAME ,c.totalPurchase() AS PVALUE
FROM client3 c;

--e)
SELECT DISTINCT c.name AS NAME ,c.totalProfit() AS PROFIT
FROM client3 c;

Labels:

DBMS III - Practicle 3

0 Comments Posted by Hirushan De Silva at 11:24 AM

DBMS prac3 Answer's Provided by Iranga & Sachit talagala


------------------ CREATE TYPES & TABLES QUERIES ------------------------------------------------------------------------------------

CREATE TYPE exchangeS_arr AS VARRAY(5) OF varchar(12)
/


CREATE TYPE stock3_t AS OBJECT
(
company char(7),
currprice number(6,2),
exchangeS exchangeS_arr,
dividend number(4,2),
eps number(4,2)
)
/


CREATE TYPE address_t AS OBJECT
(
streetNo char(4),
streetName varchar(20),
suburb varchar(20),
state varchar(10),
pin char(5)
)
/


CREATE TYPE Investments_t AS OBJECT
(
company REF stock3_t,
purchaseprice number(6,2),
pdate date,
qty number(6)
)
/


CREATE TYPE Investments_tbl AS TABLE OF Investments_t
/


CREATE TYPE client3_t AS OBJECT
(
clno char(3),
name varchar(12),
address address_t,
investments Investments_tbl
)
/


CREATE TABLE stock3 OF stock3_t
(
constraint stock_pk primary key(company)
)
/


CREATE TABLE client3 OF client3_t
(
constraint client_pk primary key(clno)
)
NESTED TABLE investments STORE AS Invest_ntbl
/



------------------- DROP QUERIES--------------------------------------------------------------------------------------


DROP TABLE client3;

DROP TABLE stock3;


DROP TYPE client3_t;

DROP TYPE Investments_tbl;

DROP TYPE Investments_t;

DROP TYPE address_t;

DROP TYPE stock3_t;

DROP TYPE exchangeS_arr;



---------------- INSERT QUERIES -------------------------------------------------------------------------------------


INSERT INTO stock3 VALUES ( stock3_t ( 'BHP', 10.50, exchangeS_arr( 'Sydney', 'New York'), 1.50, 3.20 ));
INSERT INTO stock3 VALUES ( stock3_t ( 'IBM', 70.00, exchangeS_arr( 'New York','London', 'Tokyo'), 4.25, 10.00 ));
INSERT INTO stock3 VALUES ( stock3_t ( 'INTEL', 76.50, exchangeS_arr('New York','London'), 5.00, 12.40 ));
INSERT INTO stock3 VALUES ( stock3_t ( 'FORD', 40.00, exchangeS_arr( 'New York'), 2.00, 8.50 ));
INSERT INTO stock3 VALUES ( stock3_t ( 'GM', 60.00, exchangeS_arr( 'New York'), 2.50, 9.20 ));
INSERT INTO stock3 VALUES ( stock3_t ( 'INFOSYS', 45.00, exchangeS_arr( 'New York'), 3.00, 7.80 ));




INSERT INTO client3 VALUES ( client3_t ('C01','John Smith',address_t( '3','East', 'Bentley', 'WA', '6102') ,
Investments_tbl ( Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='BHP'), 12.00,'02-Oct-2001',1000),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='BHP'), 10.50,'08-Jun-2002',2000),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='IBM'), 58.00,'12-Feb-2000',500),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='IBM'), 65.00,'10-Apr-2001',1200),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='INFOSYS'), 64.00,'11-Aug-2010',1000)
)));



INSERT INTO client3 VALUES ( client3_t ('C02','Jill Brody',address_t( '42','Bent St', 'Perth', 'WA', '6001') ,
Investments_tbl ( Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='INTEL'), 35.00,'30-Jan-2000',300),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='INTEL'), 54.00,'30-Jan-01',400),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='INTEL'), 60.00,'02-Oct-01',200),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='FORD'), 40.00,'05-Oct-99',300),
Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='GM'), 55.50,'12-Dec-00',500)
)));



----------------- SELECT QUERIES ------------------------------------------------------------------------------------


SELECT * FROM stock3;

SELECT * FROM client3;



---------------- QUERIES --------------------------------------------------------------------------------------------

--a)

SELECT DISTINCT C.name, I.company.company,I.company.currprice,I.company.dividend,I.company.eps
FROM client3 C, TABLE(C.investments) I;


--b)

SELECT DISTINCT C.name,I.company.company,SUM(I.qty) as Total_Qty,SUM(I.purchaseprice*I.qty)/SUM(I.qty) AS AVGPRICE
FROM client3 C, TABLE(C.investments) I
GROUP BY C.name,I.company.company;


--c)

SELECT C.name,I.company.company AS STOCK,SUM(I.qty) as Total_Qty ,SUM(I.company.currprice*I.qty) AS CURRVAL
FROM client3 C, TABLE(C.investments) I,TABLE(I.company.exchangeS) E
WHERE E.COLUMN_VALUE = 'New York'
GROUP BY C.name,I.company.company;


--d)

SELECT C.name,SUM(I.qty*i.purchaseprice) AS PVALUE
FROM client3 C, TABLE(C.investments) I
GROUP BY C.name;


--e)

SELECT C.name,SUM(I.qty*I.company.currprice)-SUM(I.qty*i.purchaseprice) AS PROFIT
FROM client3 C, TABLE(C.investments) I
GROUP BY C.name;



--4)---------------------------------------------------------
DELETE TABLE(SELECT c.investments FROM client3 c WHERE C.name = 'John Smith' ) i
WHERE i.company = (SELECT ref(S) FROM stock3 S WHERE S.company='INFOSYS');

INSERT INTO TABLE( SELECT c.investments FROM client3 c WHERE C.name = 'Jill Brody')
VALUES(Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='INFOSYS'), 64.00,'11-Aug-2010',1000));


DELETE TABLE(SELECT c.investments FROM client3 c WHERE C.name = 'Jill Brody' ) i
WHERE i.company = (SELECT ref(S) FROM stock3 S WHERE S.company='GM');

INSERT INTO TABLE( SELECT c.investments FROM client3 c WHERE C.name = 'John Smith')
VALUES(Investments_t ( (SELECT ref(S) FROM stock3 S WHERE S.company='GM'), 55.50,'12-Dec-00',500));

Labels:



Click Here 2 Download

First Copy Your DLL file into C:\WINDOWS\system32

and put all the image files into C:\Program Files Folder Then run the application ....

Labels:

Download Java JDK 1.6.0

0 Comments Posted by Hirushan De Silva at 6:34 PM

DCCN III LAB_2

0 Comments Posted by Hirushan De Silva at 5:32 PM


VARRAY Simple Tutorial (Oracle)

CREATE TYPE prices AS VARRY(10) OF NUMBER (5,2);

CREATE TABLE pricelist(
pno integer,
prices prices)
/

insert into pricelist values(1,prices(10.20,23.30,33.50));

select * from pricelist;

Labels:

#1 Open Notepad and paste this string into it ( without double quotes )

“X5O!P%@AP[4\PZX54(P^)7CC)7}$EICAR-STANDARD-ANTIVIRUS-TEST-FILE!$H+H* ”

#2 Save it and as soon as you do your antivirus real time protection should be able to detect it. In case you have disabled the real time protection run a scan for this file.



Labels:

Part A)

CREATE TYPE dept_t;
/

CREATE TYPE emp_t as OBJECT
(
EMPNO char(6),
FIRSTNAME varchar(12),
LASTNAME varchar(15),
WORKDEPT REF dept_t,
SEX char(1),
BIRTHDATE date,
SALARY number(8,2)
)
/

**completing de created dummi type**

CREATE TYPE dept_t as OBJECT
(
DEPTNO char(3),
DEPTNAME varchar(36),
MGRNO REF emp_t,
ADMRDEPT REF dept_t
)
/



--b)

CREATE TABLE OREMP of emp_t
(
constraint empt_pk primary key (EMPNO),
constraint emp_c1 CHECK(FIRSTNAME IS NOT NULL),
constraint emp_c2 CHECK(LASTNAME IS NOT NULL)
)
/

ALTER TABLE OREMP ADD CONSTRAINT empt_fk FOREIGN KEY(WORKDEPT) references ORDEPT;


CREATE TABLE ORDEPT of dept_t
(
constraint dept_pk primary key (DEPTNO),
constraint dept_c1 CHECK(DEPTNAME IS NOT NULL),
CONSTRAINT dept_fk1 FOREIGN KEY(MGRNO) references OREMP,
CONSTRAINT dept_fk2 FOREIGN KEY(ADMRDEPT) references ORDEPT
)
/

DROP TABLE OREMP;
DROP TABLE ORDEPT;


--c)
insert into OREMP values('000010','CHRISTINE','HAAS',NULL,'F','14-AUG-53',72750);
insert into OREMP values('000020','MICHAEL','THOMPSON',NULL,'M','02-FEB-68',612550);
insert into OREMP values('000030','SALLY','KWAN',NULL,'F','11-MAY-71',58250);
insert into OREMP values('000060','IRVING','STERN',NULL,'M','07-JUL-65',55555);
insert into OREMP values('000070','EVA','PULASKI',NULL,'F','26-MAY-73',56170);
insert into OREMP values('000050','JOHN','GEYER',NULL,'M','15-SEP-55',60175);
insert into OREMP values('000090','EILEEN','HENDERSON',NULL,'F','15-MAY-61',49750);
insert into OREMP values('000100','THEODORE','SPENSER',NULL,'M','18-DEC-76',46150);

insert into ORDEPT values('A00','SPIFFY COMPUTER SERVICE DIV',NULL,NULL);
insert into ORDEPT values('B01','PLANNING',NULL,NULL);
insert into ORDEPT values('C01','INFORMATION CENTRE ',NULL,NULL);
insert into ORDEPT values('D01','DEVELOPEMENT CENTRE',NULL,NULL);

select * from OREMP;
select * from ORDEPT;

update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='A00')
WHERE EMPNO='000010';


update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='B01')
WHERE EMPNO='000020';


update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='C01')
WHERE EMPNO='000030';


update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='D01')
WHERE EMPNO='000060';


update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='D01')
WHERE EMPNO='000070';


update OREMP
SET WORKDEPT = (select ref(b)
from ORDEPT b
where DEPTNO ='C01')
WHERE EMPNO='000050';


update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='B01')
WHERE EMPNO='000090';


update OREMP
SET WORKDEPT = (select ref(D)
from ORDEPT D
where D.DEPTNO ='B01')
WHERE EMPNO='000100';



------------

update ORDEPT
SET MGRNO = (select ref(E)
from OREMP E
where E.EMPNO ='000010')
where DEPTNO ='A00';

update ORDEPT
SET ADMRDEPT =( select ref (E)
from ORDEPT E
where E.DEPTNO ='A00')
WHERE DEPTNO='A00';



update ORDEPT
SET MGRNO = (select ref(E)
from OREMP E
where E.EMPNO ='000020')
where DEPTNO ='B01';

update ORDEPT
SET ADMRDEPT =( select ref (E)
from ORDEPT E
where E.DEPTNO ='A00')
WHERE DEPTNO='B01';



update ORDEPT
SET MGRNO = (select ref(E)
from OREMP E
where E.EMPNO ='000030')
where DEPTNO ='C01';

update ORDEPT
SET ADMRDEPT =( select ref (E)
from ORDEPT E
where E.DEPTNO ='A00')
WHERE DEPTNO='C01';



update ORDEPT
SET MGRNO = (select ref(E)
from OREMP E
where E.EMPNO ='000060')
where DEPTNO ='D01';

update ORDEPT
SET ADMRDEPT =( select ref (E)
from ORDEPT E
where E.DEPTNO ='C01')
WHERE DEPTNO='D01';



--A)
SELECT D.DEPTNAME, D.MGRNO.LASTNAME
FROM ORDEPT D;

--B)
SELECT E.EMPNO, E.LASTNAME, E.WORKDEPT.DEPTNAME
FROM OREMP E;

--C)
SELECT D.DEPTNO, D.DEPTNAME, D.ADMRDEPT.DEPTNAME
FROM ORDEPT D;

--D)
SELECT E.EMPNO, E.FIRSTNAME,E.LASTNAME, E.SALARY, E.WORKDEPT.MGRNO.LASTNAME,E.WORKDEPT.MGRNO.SALARY
FROM OREMP E;

--E)
SELECT E.WORKDEPT.DEPTNO,E.WORKDEPT.DEPTNAME, E.SEX, AVG(E.SALARY)
FROM OREMP E
GROUP BY E.WORKDEPT.DEPTNO,E.WORKDEPT.DEPTNAME,E.SEX;

Labels:




using System;
using System.Collections.Generic;
using System.ComponentModel;
using System.Data;
using System.Drawing;
using System.Text;
using System.Windows.Forms;

namespace Calculator
{
public partial class Form1 : Form
{
private double num1, num2,ans;


public Form1()
{
InitializeComponent();
label4.Text = "0";
radioButton1.Checked = true;

}

private void button1_Click(object sender, EventArgs e)
{
ans = 0;
try
{
num1 = Convert.ToDouble(textBox1.Text);
num2 = Convert.ToDouble(textBox2.Text);
}
catch (Exception er1)
{
MessageBox.Show("Invalid Number!", "Hiru Cal ERROR!", MessageBoxButtons.OK, MessageBoxIcon.Error);
}

if (radioButton1.Checked == true)
ans = num1 + num2;
else if (radioButton2.Checked == true)
ans = num1 - num2;
else if (radioButton3.Checked == true)
{
try
{
ans = num1 / num2;
}
catch (DivideByZeroException err)
{
MessageBox.Show("ERRor"+err, "Hiru Cal ERROR!", MessageBoxButtons.OK, MessageBoxIcon.Error);
};
}
else if (radioButton4.Checked == true)
ans = num1 * num2;

label4.Text = ans.ToString();

}

private void button2_Click(object sender, EventArgs e)
{
textBox1.Text = "";
textBox2.Text = "";
}


}
}


DOWNLOAD C# Calculator

Labels:

Part 1:

SELECT DISTINCT c.name,s.company,s.price,s.dividend,s.eps
FROM client c,stock s,purchase p
WHERE c.clno=p.clno AND s.company=p.company
ORDER BY c.name
;

Part 2:
SELECT c.name,p.company,sum(p.qty) as TOTAL_QTY,sum(p.qty*p.price)/sum(p.qty)as APP
FROM client c,purchase p,stock s
WHERE c.clno=p.clno AND s.company=p.company
GROUP BY p.company,c.name
ORDER BY c.name
;

Part 3:
SELECT p.company,c.name,sum(p.qty) as TOT_QTY,sum(p.qty*s.price) as Current_value
From trading t,stock s,client c,purchase p
Where t.exchange='New York' AND s.company=t.company AND c.clno=p.clno AND p.company=s.company
Group by p.company,c.name
Order by p.company
;

Part 4:

client name,purchase*qty

SELECT c.name,sum(p.qty*p.price)AS TOTAL_PRICE
FROM client c,purchase p
WHERE c.clno=p.clno
GROUP BY c.name
ORDER BY c.name
;

Party 5:

SELECT c.name,sum(p.qty*s.price)-sum(p.qty*p.price) as Book_Profit
FROM client c,stock s,purchase p
WHERE c.clno=p.clno AND s.company=p.company
GROUP BY c.name
ORDER BY c.name
;

Labels:

CREATE table client (
clno char(3)NOT NULL,
name varchar(12),
address varchar(30),
CONSTRAINT client_pk PRIMARY KEY(clno));

CREATE table stock(
company char(7),
price number(6,2),
dividend number(4,2),
eps number(4,2),
CONSTRAINT pk_stock PRIMARY KEY(company));

CREATE table trading(
company char(7),
exchange varchar(12),
CONSTRAINT pk_trading PRIMARY KEY(company,exchange),
CONSTRAINT fk_tra_stock FOREIGN KEY(company) REFERENCES stock(company));

CREATE table purchase(
clno char(3),
company char(7),
pdate date,
qty number(6),
price number(6,2),
CONSTRAINT pk_purchase PRIMARY KEY(clno,company,pdate),
CONSTRAINT fk_pur_tra FOREIGN KEY(company) REFERENCES stock(company),
CONSTRAINT fk_pur_clie FOREIGN KEY(clno) REFERENCES client(clno));


insert into client values('c01','John Smith','3 East Av Bentley WA 6102');
insert into client values('c02','Jill Brody','42 Bent St Perth WA 6001');

insert into stock values('BHP',10.50,1.50,3.20);
insert into stock values('IBM',70.00,4.25,10.00);
insert into stock values('INTEL',76.50,5.00,12.40);
insert into stock values('FORD',40.00,2.00,8.50);
insert into stock values('GM',60.00,2.50,9.20);
insert into stock values('INFOSYS',45.00,3.00,7.80);


insert into trading values('BHP','Sydney');
insert into trading values('BHP','New York');
insert into trading values('IBM','New York');
insert into trading values('IBM','London');
insert into trading values('IBM','Tokyo');
insert into trading values('INTEL','New York');
insert into trading values('INTEL','London');
insert into trading values('FORD','New York');
insert into trading values('GM','New York');
insert into trading values('INFOSYS','New York');

insert into purchase values('c01','BHP','02/OCT/01',1000,12.00);
insert into purchase values('c01','BHP','08/JUN/02',2000,10.50);
insert into purchase values('c01','IBM','12/FEB/00',500,58.00);
insert into purchase values('c01','IBM','10/APR/01',1200,65.00);
insert into purchase values('c01','INFOSYS','11/AUG/01',1000,64.00);

insert into purchase values('c02','INTEL','30/JAN/00',300,35.00);
insert into purchase values('c02','INTEL','30/JAN/01',400,54.00);
insert into purchase values('c02','INTEL','02/OCT/01',200,60.00);
insert into purchase values('c02','FORD','05/OCT/99',300,40.00);
insert into purchase values('c02','GM','12/DEC/00',500,55.50);

Labels:

Download Oracle 10g Express

0 Comments Posted by Hirushan De Silva at 6:35 AM



Download Oracle 10g Express
Step 1:
Click Accept
Step 2:
OracleXE.exe
Step 3:
username- g777444@bsnow.net
password- hirushan
Step 4:
install ...while installing give any password u like
Step 5:
start->all programs->oracle database 10g express->Run sql command line
Step 6:
sql>connect system/yourpassword
Step 7:
When yow want to copy something into the prompt Right Click Blue Menu Bar ->edit->paste

Labels:


Mpq9t-eazhx-9s3gf-x2y3z



TO DOWNLOAD CLICK HERE : (19MB)


DOWNLOAD

PASSWORD: hirushan






Visit My Site
http://hirushan.blogspot.com





Labels: ,